Het laatste nieuws en onafhankelijke reviews van de nieuwste tablets

Zo kan Google mogelijk de fragmentatie van Android aanpakken

Geschreven door
Geplaatst op9 november 2016, 10:54 CategorieAndroid

Het is geen geheim dat veel Android-gebruikers functies mislopen die later worden geïntroduceerd. Maar er is misschien een oplossing voor, zo staat te lezen in de Compatibility Design Documents van Android 7.0 Nougat.

Door fragmentatie loop je functies mis

Android is een open systeem en dat betekent dat verschillende ontwikkelaars en fabrikanten aanpassingen kunnen doen aan het OS. Maar dat betekent niet dat ook meteen alle updates, die Google zelf uitbrengt, worden doorgestuurd naar de mensen die niet gebruikmaken van Google-producten, zoals een Nexus of een Pixel. In de praktijk betekent dit dat updates bij fabrikanten blijven hangen, omdat die er geen haast achter zetten deze uit te brengen voor hun apparaten. Dat is dus niet de schuld van Google, maar het bedrijf kan het wel oplossen.

In de Compatibility Design Documents van Android 7.0 Nougat staat namelijk te lezen dat Google mogelijk een manier heeft bedacht om nieuwe features voor oudere apparaten te introduceren. Dat kan mogelijk door Android te updaten zoals Google Play Services nu wordt geüpdatet. Google kan door middel van die service nieuwe diensten en functies introduceren en dat betekent dat Android-gebruikers die nog draaien op KitKat in theorie ook gebruik kunnen maken van functionaliteiten van later uitgebrachte Android-versies.

Bekijk ook  Android-smartphones sturen locatie door naar Google, ook als locatiedienst uit staat

Om dat voor elkaar te krijgen, kan Google fabrikanten dwingen gebruik te maken van een gedeelte bibliotheek waar nieuwe functies en features worden geïntroduceerd. Middels simpele updates kan Google dan voor elk Android-apparaat nieuwe elementen introduceren. Helaas is deze informatie wel gebaseerd op wat er in de CDD staat, maar nog niet bevestigd door de zoekmachinegigant. Wat Google precies in petto heeft, is op moment van schrijven nog onduidelijk. Maar er kan in de toekomst dus een hoop gaan veranderen.

Uit de CDD:

Android includes the support of extending the managed APIs while keeping the same API level version. Android device implementations MUST preload the AOSP implementation of both the shared library ExtShared and services ExtServices with versions higher than or equal to the minimum versions allowed per each API level. For example, Android 7.0 device implementations, running API level 24 MUST include at least version 1.

  • Delen:
Google Pixel XL
Android Nougat (7.x)

Laat een reactie achter

Opmerking: E-mail wordt niet gepubliceerd of gedeeld.